본문 바로가기
자바 알고리즘/백준

백준 3085 사탕게임

by hoshi03 2024. 12. 15.

문제

상근이는 어렸을 적에 "봄보니 (Bomboni)" 게임을 즐겨했다.

가장 처음에 N×N크기에 사탕을 채워 놓는다. 사탕의 색은 모두 같지 않을 수도 있다. 상근이는 사탕의 색이 다른 인접한 두 칸을 고른다. 그 다음 고른 칸에 들어있는 사탕을 서로 교환한다. 이제, 모두 같은 색으로 이루어져 있는 가장 긴 연속 부분(행 또는 열)을 고른 다음 그 사탕을 모두 먹는다.

사탕이 채워진 상태가 주어졌을 때, 상근이가 먹을 수 있는 사탕의 최대 개수를 구하는 프로그램을 작성하시오.

입력

첫째 줄에 보드의 크기 N이 주어진다. (3 ≤ N ≤ 50)

다음 N개 줄에는 보드에 채워져 있는 사탕의 색상이 주어진다. 빨간색은 C, 파란색은 P, 초록색은 Z, 노란색은 Y로 주어진다.

사탕의 색이 다른 인접한 두 칸이 존재하는 입력만 주어진다.

출력

첫째 줄에 상근이가 먹을 수 있는 사탕의 최대 개수를 출력한다.

예제 입력 1 복사

3
CCP
CCP
PPC

예제 출력 1 복사

3

예제 입력 2 복사

4
PPPP
CYZY
CCPY
PPCC

예제 출력 2 복사

4

예제 입력 3 복사

5
YCPZY
CYZZP
CCPPP
YCYZC
CPPZZ

예제 출력 3 복사

4

 

• 풀이

 

보드 크기 최대 50

n^2으로 보드 전체를 순회하면서 최대 사탕 갯수를 구할 수 있음

n^2으로 보드에서 연속된 칸의 패턴이 다르면 스왑하고 원복가능

n^4을 박아도 625만번이기에 가능하다고 생각하고 n^4으로 풀었다

 

import java.util.*;
import java.io.*;

class Main {
    static char[][] arr;
    static int n;

    public static int getMax() {
        int maxCount = 0;
        for (int i = 0; i < n; i++) {
            int count = 1;
            for (int j = 1; j < n; j++) {
                if (arr[i][j] == arr[i][j - 1]) count++;
                else {
                    maxCount = Math.max(maxCount, count);
                    count = 1;
                }
            }
            maxCount = Math.max(maxCount, count);
        }

        for (int i = 0; i < n; i++) {
            int count = 1;
            for (int j = 1; j < n; j++) {
                if (arr[j][i] == arr[j - 1][i]) count++;
                else {
                    maxCount = Math.max(maxCount, count);
                    count = 1;
                }
            }
            maxCount = Math.max(maxCount, count);
        }
        return maxCount;
    }

    public static void main(String[] args) throws IOException {
        BufferedReader br = new BufferedReader(new InputStreamReader(System.in));

        n = Integer.parseInt(br.readLine());
        arr = new char[n][n];

        for (int i = 0; i < n; i++) {
            String s = br.readLine();
            for (int j = 0; j < n; j++) {
                arr[i][j] = s.charAt(j);
            }
        }

        int res = getMax();

        for (int i = 0; i < n; i++) {
            for (int j = 0; j < n; j++) {
                if (j + 1 < n && arr[i][j] != arr[i][j + 1]) {
                    swap(i, j, i, j + 1);
                    res = Math.max(res, getMax());
                    swap(i, j, i, j + 1);
                }

                if (i + 1 < n && arr[i][j] != arr[i + 1][j]) {
                    swap(i, j, i + 1, j);
                    res = Math.max(res, getMax());
                    swap(i, j, i + 1, j);
                }
            }
        }

        System.out.println(res);
    }

    public static void swap(int x1, int y1, int x2, int y2) {
        char temp = arr[x1][y1];
        arr[x1][y1] = arr[x2][y2];
        arr[x2][y2] = temp;
    }
}

 

'자바 알고리즘 > 백준' 카테고리의 다른 글

백준 18870 : 좌표압축 (TreeMap)  (1) 2024.12.19
백준 1730 : 판화 (구현)  (3) 2024.12.16
11068 : 회문인 수  (1) 2024.12.15
백준 2108 : 통계학(구현?)  (0) 2024.11.19
백준 18110 ( 구현, 정렬, 소수점 처리)  (0) 2024.11.18