시간 제한메모리 제한제출정답맞힌 사람정답 비율
2 초 | 256 MB | 177833 | 74687 | 55975 | 40.420% |
문제
알파벳 소문자로 이루어진 N개의 단어가 들어오면 아래와 같은 조건에 따라 정렬하는 프로그램을 작성하시오.
- 길이가 짧은 것부터
- 길이가 같으면 사전 순으로
단, 중복된 단어는 하나만 남기고 제거해야 한다.
입력
첫째 줄에 단어의 개수 N이 주어진다. (1 ≤ N ≤ 20,000) 둘째 줄부터 N개의 줄에 걸쳐 알파벳 소문자로 이루어진 단어가 한 줄에 하나씩 주어진다. 주어지는 문자열의 길이는 50을 넘지 않는다.
출력
조건에 따라 정렬하여 단어들을 출력한다.
예제 입력 1 복사
13
but
i
wont
hesitate
no
more
no
more
it
cannot
wait
im
yours
예제 출력 1 복사
i
im
it
no
but
more
wait
wont
yours
cannot
hesitate
import java.io.*;
import java.util.*;
class Words implements Comparable<Words>{
String word;
Words(String word){
this.word = word;
}
@Override
public int compareTo(Words o) {
if (o.word.length() == word.length()){
return word.compareTo(o.word);
}
else return word.length() - o.word.length();
}
}
public class Main {
public static void solution(char[][] arr, String s) {
}
public static void main(String[] args) throws IOException {
Scanner in = new Scanner(System.in);
int n = in.nextInt();
in.nextLine();
TreeSet<Words> tr = new TreeSet<>();
for (int i = 0; i < n; i++) tr.add(new Words(in.nextLine()));
ArrayList<Words> arr = new ArrayList<>(tr);
Collections.sort(arr);
for (Words x : arr) System.out.println(x.word);
}
}
트리셋에 넣었다가 빼서 중복을 제거하고
클래스를 만들고 Comparable 인터페이스를 구현해서 그 안에서 정렬을 했다.
중복을 제거하는 방법은 위에처럼 트리셋을 쓰거나 정렬된 단어가 이전 단어와 같으면 출력하지 않는 방법 두가지로
처리 가능하다
'자바 알고리즘 > 백준' 카테고리의 다른 글
백준 18870 좌표압축 (1) | 2024.03.12 |
---|---|
7785 회사에 있는 사람 (0) | 2024.03.08 |
백준 2817 (1) | 2024.02.16 |
백준 11005 진법 변환 2 (1) | 2024.01.31 |
백준 10989 (1) | 2024.01.29 |