본문 바로가기
자바 알고리즘/백준

백준 1260 : DFS와 BFS

by hoshi03 2024. 4. 7.

문제

그래프를 DFS로 탐색한 결과와 BFS로 탐색한 결과를 출력하는 프로그램을 작성하시오. 단, 방문할 수 있는 정점이 여러 개인 경우에는 정점 번호가 작은 것을 먼저 방문하고, 더 이상 방문할 수 있는 점이 없는 경우 종료한다. 정점 번호는 1번부터 N번까지이다.

입력

첫째 줄에 정점의 개수 N(1 ≤ N ≤ 1,000), 간선의 개수 M(1 ≤ M ≤ 10,000), 탐색을 시작할 정점의 번호 V가 주어진다. 다음 M개의 줄에는 간선이 연결하는 두 정점의 번호가 주어진다. 어떤 두 정점 사이에 여러 개의 간선이 있을 수 있다. 입력으로 주어지는 간선은 양방향이다.

출력

첫째 줄에 DFS를 수행한 결과를, 그 다음 줄에는 BFS를 수행한 결과를 출력한다. V부터 방문된 점을 순서대로 출력하면 된다.

예제 입력 1 복사

4 5 1
1 2
1 3
1 4
2 4
3 4

예제 출력 1 복사

1 2 4 3
1 2 3 4

예제 입력 2 복사

5 5 3
5 4
5 2
1 2
3 4
3 1

예제 출력 2 복사

3 1 2 5 4
3 1 4 2 5

예제 입력 3 복사

1000 1 1000
999 1000

예제 출력 3 복사

1000 999
1000 999

 

풀이

 

dfs, bfs로 정점 순회를 하는 문제다

 

• 인접 행렬 - 2차원 배열 선언하고  값을 넣어준다

   	static int[][] adj; // 인접 행렬
    
        //인접 행렬
        adj = new int[N+1][N+1];
        //간선의 갯수만큼 입력 받기
        for (int i = 1; i <= M; i++){
            int a = in.nextInt();
            int b = in.nextInt();
            //양방향이니까 양쪽 다 연결해주기
            adj[a][b] = 1;
            adj[b][a] = 1;
        }

 

• 인접 행렬로 dfs, bfs 하는 경우

 static void dfs(int x){
        //각 정점별로 visited는 한번씩만 호출된다
        visited[x] = true;
        System.out.print(x + " ");

        for (int y = 1; y <= N; y++){
            if (adj[x][y] == 0) continue;
            if (visited[y]) continue;
            dfs(y);
        }
    }

    static void bfs(int start){
        Queue<Integer> queue = new LinkedList<>();
        //처음에 방문하는 start를 큐에 넣고 시작한다
        queue.add(start);
        visited[start] = true; // 큐에 넣은건 방문한 정점이다

        //더 방문할 정점이 없을 때 까지
        while (!queue.isEmpty()){
            int x = queue.poll();
            System.out.print(x + " ");

            for (int y = 1; y <= N; y++){
                if (adj[x][y] == 0) continue;
                if (visited[y]) continue;
                queue.add(y);
                visited[y] = true;
            }
        }
    }

 

• 인접 리스트

ArrayList<Integer>[] 형태로 선언하고 arr[i] 마다 각각 ArrayList를 넣은 다음

값을 넣은 후 작은 정점부터 순서대로 가기 위해서 arr[i] 안에 잇는 ArrayList를 Collections.sort(arr[i])로 정렬해준다 

	static ArrayList<Integer>[] arr; //인접 리스트 선언
        
        //인접 리스트
        arr = new ArrayList[N+1];
        for (int i = 1; i <= N; i++) arr[i] = new ArrayList<Integer>();

        for (int i = 1; i <= M; i++){
            int a = in.nextInt();
            int b = in.nextInt();
            arr[a].add(b);
            arr[b].add(a);
        }

        //작은 정점부터 순서대로 가야 되니까 정렬을 해준다
        for (int i = 1; i <= N; i++)  Collections.sort(arr[i]);

 

• 인접 리스트로 dfs, bfs 하는 경우

for (int y : arr[x]) 형태로 인접 리스트에 연결된 정점을 바로 탐색할 수 있어서 더 편하게 접근할 수 있다

 static void dfs(int x){
        //각 정점별로 visited는 한번씩만 호출된다
        visited[x] = true;
        System.out.print(x + " ");

        for (int y : arr[x]){
            if (visited[y]) continue;
            dfs(y);
        }
    }

    static void bfs(int start){
        Queue<Integer> queue = new LinkedList<>();
        //처음에 방문하는 start를 큐에 넣고 시작한다
        queue.add(start);
        visited[start] = true; // 큐에 넣은건 방문한 정점이다

        //더 방문할 정점이 없을 때 까지
        while (!queue.isEmpty()){
            int x = queue.poll();
            System.out.print(x + " ");

            for (int y : arr[x]){
                if (visited[y]) continue;
                queue.add(y);
                visited[y] = true;
            }
        }
    }

 

• 전체 코드

 

import java.io.*;
import java.sql.Array;
import java.util.*;

public class Main {

    static int N, M, V;
    static int[][] adj; // 인접 행렬
    static ArrayList<Integer>[] arr;
    static boolean[] visited;

    static void dfs(int x){
        //각 정점별로 visited는 한번씩만 호출된다
        visited[x] = true;
        System.out.print(x + " ");

        for (int y : arr[x]){
            if (visited[y]) continue;
            dfs(y);
        }
    }

    static void bfs(int start){
        Queue<Integer> queue = new LinkedList<>();
        //처음에 방문하는 start를 큐에 넣고 시작한다
        queue.add(start);
        visited[start] = true; // 큐에 넣은건 방문한 정점이다

        //더 방문할 정점이 없을 때 까지
        while (!queue.isEmpty()){
            int x = queue.poll();
            System.out.print(x + " ");

            for (int y : arr[x]){
                if (visited[y]) continue;
                queue.add(y);
                visited[y] = true;
            }
        }
    }

    public static void main(String[] args) throws IOException {
        BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
        Scanner in =new Scanner(System.in);

        N = in.nextInt();
        M = in.nextInt();
        V = in.nextInt();
        visited = new boolean[N+1];
        
        //인접 행렬
        adj = new int[N+1][N+1];
        //간선의 갯수만큼 입력 받기
        for (int i = 1; i <= M; i++){
            int a = in.nextInt();
            int b = in.nextInt();
            //양방향이니까 양쪽 다 연결해주기
            adj[a][b] = 1;
            adj[b][a] = 1;
        }
        
        //인접 리스트
        arr = new ArrayList[N+1];
        for (int i = 1; i <= N; i++) arr[i] = new ArrayList<Integer>();

        for (int i = 1; i <= M; i++){
            int a = in.nextInt();
            int b = in.nextInt();
            arr[a].add(b);
            arr[b].add(a);
        }

        //작은 정점부터 순서대로 가야 되니까 정렬을 해준다
        for (int i = 1; i <= N; i++)  Collections.sort(arr[i]);


        dfs(V);
        System.out.println();
        for (int i = 1; i <= N; i++) visited[i] = false; //방문 여부 초기화해줘야 bfs도 제데로 나옴
        bfs(V);

    }
}