문제
루트 없는 트리가 주어진다. 이때, 트리의 루트를 1이라고 정했을 때, 각 노드의 부모를 구하는 프로그램을 작성하시오.
입력
첫째 줄에 노드의 개수 N (2 ≤ N ≤ 100,000)이 주어진다. 둘째 줄부터 N-1개의 줄에 트리 상에서 연결된 두 정점이 주어진다.
출력
첫째 줄부터 N-1개의 줄에 각 노드의 부모 노드 번호를 2번 노드부터 순서대로 출력한다.
예제 입력 1 복사
7
1 6
6 3
3 5
4 1
2 4
4 7
예제 출력 1 복사
4
6
1
3
1
4
예제 입력 2 복사
12
1 2
1 3
2 4
3 5
3 6
4 7
4 8
5 9
5 10
6 11
6 12
예제 출력 2 복사
1
1
2
3
3
4
4
5
5
6
6
풀이
트리의 부모는 bfs로 탐색했을때 자기를 호출한 바로 이전 노드
bfs를 하면서 이어진 노드를 큐에 넣기 전에 자기가 호출했다는걸 적어주면 됐었다
import java.util.*;
public class Main {
static int N, M, res = 0;
static ArrayList<Integer>[] arr;
static boolean[] visited;
static int[] parents;
static void bfs(int start){
Queue<Integer> queue =new LinkedList<>();
queue.add(start);
visited[start] = true;
while (!queue.isEmpty()){
int tmp = queue.poll();
for (int x : arr[tmp]){
if (visited[x]) continue;
queue.add(x);
visited[x] = true;
parents[x] = tmp;
}
}
}
public static void main(String[] args) {
Scanner in = new Scanner(System.in);
N = in.nextInt(); // 노드 갯수
arr = new ArrayList[N+1];
visited = new boolean[N+1];
parents = new int[N+1];
for (int i = 1; i <= N; i++) arr[i] = new ArrayList<>();
for (int i = 0; i < N-1; i++){
int a = in.nextInt();
int b = in.nextInt();
arr[a].add(b);
arr[b].add(a);
}
bfs(1);
for (int i =2; i <= N; i++) System.out.println(parents[i]);
}
}
'자바 알고리즘 > 백준' 카테고리의 다른 글
백준 2178 : 미로 탐색 (0) | 2024.04.10 |
---|---|
백준 2251 : 물통 (0) | 2024.04.10 |
백준 2606 : 바이러스 (0) | 2024.04.09 |
백준 3184 : 양 (0) | 2024.04.09 |
백준 4963 : 섬의 개수 (0) | 2024.04.09 |